sergiors/doctrine-orm-service-provider

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.

Doctrine ORM for Pimple

1.0.0 2017-12-11 01:35 UTC

This package is not auto-updated.

Last update: 2021-09-17 00:36:57 UTC


README

Build Status

Install

composer require sergiors/doctrine-orm-service-provider "dev-master"

How to use

Something like this

use Silex\Provider\DoctrineServiceProvider;
use Sergiors\Pimple\Provider\DoctrineOrmServiceProvider;
use Sergiors\Pimple\Provider\DoctrineCacheServiceProvider;

$app->register(new DoctrineServiceProvider(), [
    // your db config
]);
$app->register(new DoctrineCacheServiceProvider());
$app->register(new DoctrineOrmServiceProvider(), [
    'orm.proxy_dir' => '',
    'orm.proxy_namespace' => ''
]);

$app['orm']->getRepository('Namespace\Entity\User')->findAll();

License

MIT