A RESTful API package for the Laravel and Lumen frameworks.

v3.1.1 2022-01-30 13:37 UTC

This package is auto-updated.

Last update: 2022-06-29 02:10:04 UTC


README

Note: This is an official and reasonably maintained fork of the popular https://github.com/dingo/api repository by one of the maintainers of that project. The reason it was forked is due to broken integrations with CI tools such as travis (which can only be fixed by owner), and in general to be able to better support the project and ensure non-breaking updates.

In order to move to this repo, you merely need to update your composer file. All the namespaces and other aspects of the project are the same. Example instructions are below, to use the latest version:

composer remove dingo/api
composer require api-ecosystem-for-laravel/dingo-api

Please note, we do not actively maintain the Lumen support of this project. If you are still using Lumen, we recommend you migrate to Laravel.

The Dingo API package is meant to provide you, the developer, with a set of tools to help you easily and quickly build your own API. While the goal of this package is to remain as flexible as possible it still won't cover all situations and solve all problems.

Build Status License Development Version Monthly Installs StyleCI

Features

This package provides tools for the following, and more:

  • Content Negotiation
  • Multiple Authentication Adapters
  • API Versioning
  • Rate Limiting
  • Response Transformers and Formatters
  • Error and Exception Handling
  • Internal Requests
  • API Blueprint Documentation

Documentation

Please refer to our extensive Wiki documentation for more information.

API Boilerplate

If you are looking to start a new project from scratch, consider using the Laravel API Boilerplate, which builds on top of the dingo-api package, and adds a lot of great features.

Support

For answers you may not find in the Wiki, avoid posting issues. Feel free to ask for support on the dedicated Slack room. Make sure to mention specialtactics so he is notified.

License

This package is licensed under the BSD 3-Clause license.