bit3/composer-global-depends

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.
This package is abandoned and no longer maintained. No replacement package was suggested.

Analyse which package depends on another one globally.

1.0.0 2015-01-31 12:50 UTC

This package is not auto-updated.

Last update: 2020-01-24 15:31:41 UTC


README

Version Stable Build Status Code Quality Dependencies License Downloads

Global dependency analyser

Search for packages that depend on another package globally!

Installation

$ php composer.phar create-project bit3/composer-global-depends dev-master

Usage

$ cd composer-global-depends
$ ./bin/composer-global-depends.php phpmd/phpmd
[acquia/acquia-search-proxy 0.2.x-dev] require-dev phpmd/phpmd ~1.0                   
[acquia/acquia-search-proxy dev-master] require-dev phpmd/phpmd ~1.0                  
[acquia/acquia-search-proxy 0.2.x-dev] require-dev phpmd/phpmd ~1.0                   
[acquia/acquia-search-proxy dev-master] require-dev phpmd/phpmd ~1.0                  
  1182 [------>---------------------] 5 secs   albertofem/translatableroutepath-bundle
...