sentry/sentry-laravel

Laravel SDK for Sentry (https://sentry.io)

Fund package maintenance!
sentry.io/pricing
sentry.io

Installs: 35 691 295

Dependents: 96

Suggesters: 2

Security: 0

Stars: 1 089

Watchers: 42

Forks: 167

Open Issues: 6


README

Sentry

Bad software is everywhere, and we're tired of it. Sentry is on a mission to help developers write better software faster, so we can get back to enjoying technology. If you want to join us Check out our open positions

Official Sentry SDK for Laravel

CI Latest Stable Version License Total Downloads Monthly Downloads Discord

This is the official Laravel SDK for Sentry

Getting Started

The installation step below work on the latest versions of the Laravel framework (8.x and 9.x).

For other Laravel or Lumen versions see:

Install

Install the sentry/sentry-laravel package:

composer require sentry/sentry-laravel

Enable capturing unhandled exception to report to Sentry by making the following change to your App/Exceptions/Handler.php:

use Sentry\Laravel\Integration;

public function register()
{
    $this->reportable(function (Throwable $e) {
        Integration::captureUnhandledException($e);
    });
}

Alternatively, you can configure Sentry in your Laravel Log Channel, allowing you to log info and debug as well.

Configure

Configure the Sentry DSN with this command:

php artisan sentry:publish --dsn=___PUBLIC_DSN___

It creates the config file (config/sentry.php) and adds the DSN to your .env file.

SENTRY_LARAVEL_DSN=___PUBLIC_DSN___

Usage

try {
    $this->functionFailsForSure();
} catch (\Throwable $exception) {
    \Sentry\captureException($exception);
}

Laravel Version Compatibility

The Laravel versions listed below are all currently supported:

  • Laravel >= 6.x.x on PHP >= 7.2 is supported starting from 1.2.0
  • Laravel >= 7.x.x on PHP >= 7.2 is supported starting from 1.7.0
  • Laravel >= 8.x.x on PHP >= 7.3 is supported starting from 1.9.0
  • Laravel >= 9.x.x on PHP >= 8.0 is supported starting from 2.11.0

Please note that starting with version >= 2.0.0 we require PHP Version >= 7.2 because we are using our new PHP SDK underneath.

The Laravel and Lumen version listed below were supported in previous versions:

  • Laravel <= 4.2.x is supported until 0.8.x
  • Laravel <= 5.7.x on PHP <= 7.0 is supported until 0.11.x
  • Laravel >= 5.x.x on PHP >= 7.1 is supported until 2.14.x
  • Laravel Lumen is supported until 2.14.x

Contributing to the SDK

Please refer to CONTRIBUTING.md.

Getting help/support

If you need help setting up or configuring the Laravel SDK (or anything else in the Sentry universe) please head over to the Sentry Community on Discord. There is a ton of great people in our Discord community ready to help you!

Resources

  • Documentation
  • Discord
  • Stack Overflow
  • Twitter Follow

License

Licensed under the Apache 2.0 license, see LICENSE