longlang/phpkafka

A kafka client. Support php-fpm and Swoole.

v1.2.0 2021-09-11 02:54 UTC

This package is auto-updated.

Last update: 2021-10-17 11:37:56 UTC


README

Latest Version Php Version License

Introduction

English | 简体中文

PHP Kafka client is used in PHP-FPM and Swoole.

The communication protocol is based on the JSON file in Java. PHP Kafka client supports 50 APIs, which might be one that supports the most message types ever.

The produce and the consume of messages are implemented. The component is in developing and testing.

Features

  • Support all 50 APIs
  • Message compression
  • PHP-FPM and Swoole compatible
  • Producer
  • Consumer
  • SASL
  • SSL
  • More features and test cases

Environment

  • PHP >= 7.1
  • Kafka >= 1.0.0
  • Swoole >= 4.5 (optional)

Installation

composer require longlang/phpkafka

Documentation and Examples

Refer to examples for code examples.