spiral/symfony-messenger

Symfony Messenger integration for Spiral

dev-master 2024-06-28 13:53 UTC

This package is auto-updated.

Last update: 2024-06-28 13:53:54 UTC


README

This is my package symfony-messenger

PHP Version Require Latest Stable Version phpunit psalm Codecov Total Downloads

This is where your description should go. Limit it to a paragraph or two. Consider adding a small example.

Requirements

Make sure that your server is configured with following PHP version and extensions:

  • PHP 8.2+
  • Spiral framework 3.13+

Installation

You can install the package via composer:

composer require spiral/symfony-messenger

After package install you need to register bootloader from the package.

// Kernel.php
public function defineBootloaders(): array
{
    return [
        // ...
        \Spiral\Messenger\Bootloader\MessengerBootloader::class,
        // ...
    ];
}

Note: if you are using spiral/discoverer, you don't need to register bootloader by yourself.

Testing

composer test

Changelog

Please see CHANGELOG for more information on what has changed recently.

Contributing

Please see CONTRIBUTING for details.

License

The MIT License (MIT). Please see License File for more information.