silverware/userforms

SilverWare UserForms Module.

Installs: 35

Dependents: 0

Suggesters: 0

Stars: 0

Watchers: 1

Forks: 0

Open Issues: 0

Language:JavaScript

Type:silverstripe-vendormodule

1.0.1 2018-09-14 04:17 UTC

README

Latest Stable Version Latest Unstable Version License

Extends the SilverStripe UserForms Module for use with SilverWare apps.

Contents

Requirements

Installation

Installation is via Composer:

$ composer require silverware/userforms

Configuration

By default, this module will disable the built-in CSS and JavaScript that is required by silverstripe/userforms. This is achieved within the config.yml file with the following configuration:

SilverStripe\UserForms\Model\UserDefinedForm:
  block_default_userforms_js: true
  block_default_userforms_css: true

The configuration file also changes the user form validator to an instance of SilverWare Validator using the following configuration:

SilverStripe\UserForms\Form\UserForm:
  custom_validator_class: SilverWare\Validator\Validator
  custom_validator_enabled: true

Usage

This module adds an extension to the UserForm class which replaces the standard validator class with an instance of SilverWare Validator. This extension also adds a further extension point to UserForm named updateValidator, if you need to further customise the validator instance.

Template overrides are also provided by this module which replace the standard user form templates with ones that will render correctly in SilverWare apps, namely with Bootstrap 4 theme classes and the Parsley.js validation errors provided by SilverWare Validator.

Issues

Please use the issue tracker for bug reports and feature requests.

Contribution

Your contributions are gladly welcomed to help make this project better. Please see contributing for more information.

Maintainers

Colin Tucker Praxis Interactive
Colin Tucker Praxis Interactive

License

BSD-3-Clause © Praxis Interactive