ricadesign/paylands-php

Paynopain Paylands service

v0.2.0 2021-06-04 12:21 UTC

This package is auto-updated.

Last update: 2021-07-04 12:32:54 UTC


README

Build Status Latest Stable Version Total Downloads License

You can get your Paylands account at Paynopain @Payments

Requirements

PHP 5.5.0 and later.

Installation

You can install the library via Composer. Run the following command:

composer require wearemarketing/paylands-php

To use the library, use Composer's autoload:

require_once('vendor/autoload.php');

We use HTTPPlug as the HTTP client abstraction layer, so you must install an HTTP client implementation an its corresponding adapter. In the followingnexample, we will use a Guzzle adapter to provide dependencies.

composer require php-http/guzzle6-adapter

If you want to use another HTTP client implementation, you can check here the full list of HTTP client implementations.

Documentation

Please see integration tests. For up-to-date documentation about Paylands API see docs.

Development

To execute the test suite just follow next steps.

composer install

Install dependencies as mentioned above (which will resolve PHPUnit), then you can run the test suite:

./vendor/bin/phpunit

To enable integration tests you must set your API keys in the PHPUnit's config file (see phpunit.xml.dist)

Community

Find some of the community-supported libraries available for Paylands PHP listed below.