This package is abandoned and no longer maintained. The author suggests using the ramsey/vnderror package instead.

application/vnd.error builder / formatter for PHP 5.3+

3.0.1 2016-02-15 16:13 UTC


Build Status Coverage Status Latest Stable Version Total Downloads Latest Unstable Version License

Ramsey\VndError is a PHP implementation of the vnd.error specification. This implementation currently targets the e88d5cd1ad revision of the specification.

From the vnd.error specification:

vnd.error is a simple way of expressing an error response in XML or JSON.

Often when returning a response to a client a response type is needed to represent a problem to the user (human or otherwise). A media type representation is a convenient way of expressing the error in a standardised format and can be understood by many client applications.


Use application/vnd.error+json or application/vnd.error+xml media types to communicate errors with HTTP 4xx and 5xx status codes.

use Ramsey\VndError\VndError;

$vndError = new VndError('Validation failed', 42);
$vndError->addLink('help', 'http://.../', array('title' => 'Error Information'));
$vndError->addLink('describes', 'http://.../', array('title' => 'Error Description'));

JSON output (application/vnd.error+json):

header('Content-Type: application/vnd.error+json');
echo $vndError->asJson();

Results in:

    "message": "Validation failed",
    "logref": 42,
    "_links": {
        "help": {
            "href": "http://.../",
            "title": "Error Information"
        "describes": {
            "href": "http://.../",
            "title": "Error Description"

XML output (application/vnd.error+xml)

header('Content-Type: application/vnd.error+xml');
echo $vndError->asXml();

Results in:

<?xml version="1.0"?>
<resource logref="42">
    <link rel="help" href="http://.../" title="Error Information"/>
    <link rel="describes" href="http://.../" title="Error Description"/>
    <message>Validation failed</message>


The preferred method of installation is via Composer:

php composer.phar require ramsey/vnderror