php-translation/loco-adapter

Adapter for loco.

0.8.0 2018-06-27 15:39 UTC

README

Latest Version Build Status Code Coverage Quality Score Total Downloads

This is an PHP-translation adapter for Loco (Localise.biz).

Install

composer require php-translation/loco-adapter
Symfony bundle

If you want to use the Symfony bundle you may activate it in kernel:

// app/AppKernel.php

public function registerBundles()
{
    $bundles = array(
        // ...
        new Translation\PlatformAdapter\Loco\Bridge\Symfony\TranslationAdapterLocoBundle(),
    );
}

If you have one Loco project per domain you may configure the bundle like this:

# /app/config/config.yml
translation_adapter_loco:
  index_parameter: 'id' # 'text' or 'name'. Leave blank for "auto"  See https://localise.biz/api/docs/export/exportlocale
  projects:
    messages:
      api_key: 'foobar' 
    navigation:
      api_key: 'bazbar' 

If you just doing one project and have tags for all your translation domains you may use this configuration:

# /app/config/config.yml
translation_adapter_loco:
  index_parameter: 'id' # 'text' or 'name'. Leave blank for "auto"  See https://localise.biz/api/docs/export/exportlocale
  projects:
    acme:
      api_key: 'foobar'   
      domains: ['messages', 'navigation']

This will produce a service named php_translation.adapter.loco that could be used in the configuration for the Translation Bundle.

Documentation

Read our documentation at http://php-translation.readthedocs.io.

Contribute

Do you want to make a change? Pull requests are welcome.