monii/container-interop-laravel

Laravel adapter for Container Interop

v1.0.1 2015-09-22 13:07 UTC

README

A Container Interop adapter for Laravel's Container.

Latest Stable Version Total Downloads Latest Unstable Version License
Build Status

Requirements

  • PHP 5.5+
  • illuminate/contracts ^5.0

Installation

$> composer require monii/container-interop-laravel

Usage

use Illuminate\Container\Container;
use Monii\Interop\Container\Laravel\LaravelContainer;

$actualLaravelContainer = new Container();
$container = new LaravelContainer($actualLaravelContainer);

// $container implements Interop\Container\ContainerInterface

Service Provider

In your application configuration add Monii\Interop\Container\Laravel\ServiceProvider to your providers array.

$container = App::make('Interop\Container\ContainerInterface');

License

MIT, see LICENSE.

Community

Want to get involved? Here are a few ways:

  • Find us in the #monii IRC channel on irc.freenode.org.
  • Mention @moniidev on Twitter.