luxifer/dependensees

Command-line tool to check wether composer dependencies are up to date

Installs: 1 298

Dependents: 0

Stars: 1

Watchers: 1

Language: PHP

1.3.2 2015-02-12 08:26 UTC

README

Latest Stable Version Total Downloads Scrutinizer Quality Score

Installation

{
    "require": {
        "luxifer/dependensees": "dev-master"
    },
    "config": {
        "bin-dir": "bin/"
    }
}

Usage

$ php bin/dependensees

Command output

Name        : luxifer/dependensees
version     : 1.1.0
Description : Command-line tool to check wether composer dependencies are up to date
Stability   : stable

Processing.......

Name                    | Installed  | Required       | Available  | Outdated
------------------------+------------+----------------+------------+---------
symfony/console         | v2.3.1     | >=2.1,<2.4-dev | v2.3.1     | -
composer/composer       | dev-master | 1.0.*@dev      | dev-master | -
guzzle/guzzle           | v3.7.1     | *              | v3.7.1     | -
symfony/filesystem      | v2.3.1     | >=2.1,<2.4-dev | v2.3.1     | -
components/bootstrap    | 2.3.2      | 2.3.2          | 2.3.2      | -
twig/twig               | v1.13.1    | 1.*            | v1.13.1    | -
components/font-awesome | 3.2.0      | 3.2.0          | 3.2.0      | -

0 of 7 packages are outdated.

Building HTML status page... Done!

TODO

  • Add XML status result for continuous integration
  • Add semantic version comparison for stable packages
  • Add phar compiler