friends-of-phpspec/phpspec-expect

Helper that decorates any SUS with a phpspec lazy object wrapper

4.0.1 2021-01-20 22:09 UTC

This package is auto-updated.

Last update: 2021-09-20 23:40:18 UTC


README

Latest Stable Version GitHub stars Total Downloads GitHub Workflow Status License

phpspec-expect

Install

Install this package as a development dependency in your project:

$ composer require --dev friends-of-phpspec/phpspec-expect

Usage

Inside some example:

expect(file_exists('dummy.txt'))->toBe(true);

Compatibility

phpspec-expect PHP phpspec
2.x >=5.6 ^3.0
3.0.x >=7.0 ^4.0
3.1.x ^7.1 ^5.0 || ^6.0
4.x >=7.3 ^6.0 || ^7.0

Authors

Copyright (c) 2017-2020 BossaConsulting (https://github.com/BossaConsulting/phpspec2-expect).

License

Licensed under MIT License.