alessandrominoccheri/wordpress-rest-api-client

There is no license information available for the latest version (v1.3.4) of this package.

v1.3.4 2019-07-25 10:16 UTC

This package is auto-updated.

Last update: 2020-07-25 13:03:20 UTC


README

A Wordpress REST API client for PHP

Travis

For when you need to make Wordpress REST API calls from some other PHP project, for some reason.

Installation

This library can be installed with Composer:

composer require alessandrominoccheri/wordpress-rest-api-client

The library will require an Http library to run. Guzzle is supported by the library, but you can use any Http library of your choise, so long as your write an adapter for that library.

To install Guzzle:

composer require guzzlehttp/guzzle

Usage

Example:

use Vnn\WpApiClient\Auth\WpBasicAuth;
use Vnn\WpApiClient\Http\GuzzleAdapter;
use Vnn\WpApiClient\WpClient;

require 'vendor/autoload.php';

$client = new WpClient(new GuzzleAdapter(new GuzzleHttp\Client()), 'http://yourwordpress.com');
$client->setCredentials(new WpBasicAuth('user', 'securepassword'));

$user = $client->users()->get(2);

print_r($user);

Testing

composer install
vendor/bin/peridot