The Smarty integration for the Yii framework

Installs: 4 036

Dependents: 2

Stars: 19

Watchers: 13

Forks: 15

Language: PHP

2.0.4 2015-05-25 20:59 UTC


This extension provides a ViewRender that would allow you to use Smarty view template engine with Yii framework 2.0.

For license information check the LICENSE-file.

Documentation is at docs/guide/README.md.

Latest Stable Version Total Downloads Build Status


The preferred way to install this extension is through composer.

Either run

php composer.phar require --prefer-dist yiisoft/yii2-smarty

or add

"yiisoft/yii2-smarty": "~2.0.0"

to the require section of your composer.json.

Note that the smarty composer package is distributed using subversion so you may need to install subversion.


To use this extension, simply add the following code in your application configuration:

return [
    'components' => [
        'view' => [
            'renderers' => [
                'tpl' => [
                    'class' => 'yii\smarty\ViewRenderer',
                    //'cachePath' => '@runtime/Smarty/cache',