yii2mod/yii2-markdown

Markdown Widget for Yii2

Installs: 38 119

Dependents: 7

Suggesters: 0

Security: 0

Stars: 13

Watchers: 3

Forks: 3

Open Issues: 0

Type:yii2-extension

1.1 2017-11-24 15:38 UTC

This package is not auto-updated.

Last update: 2024-04-13 23:09:31 UTC


README

993323

Markdown Widget for Yii 2


Widget based on SimpleMDE - Markdown Editor

Latest Stable Version Total Downloads License Build Status

Installation

The preferred way to install this extension is through composer.

Either run

php composer.phar require --prefer-dist yii2mod/yii2-markdown "*"

or add

"yii2mod/yii2-markdown": "*"

to the require section of your composer.json.

Usage

Once the extension is installed, simply add widget to your page as follows:

  1. Usage with ActiveForm and model
<?php echo $form->field($model, 'content')->widget(\yii2mod\markdown\MarkdownEditor::class, [
    'editorOptions' => [
        'showIcons' => ["code", "table"],
    ],
]); ?>
  1. Usage without ActiveForm and model
<?php echo \yii2mod\markdown\MarkdownEditor::widget([
    'name' => 'markdown-editor',
    'editorOptions' => [
        'showIcons' => ["code", "table"],
    ],
]);
?>

Markdown Editor Options

You can find them on the options page