wilbur-yu/hyperf-opcache

PHP Opcache command for Hyperf

0.0.5 2021-12-13 15:45 UTC

This package is auto-updated.

Last update: 2022-09-13 17:45:19 UTC


README

PHP Opcache command for Hyperf

description

Transplantation in laravel-opcache Opcache configuration reference OPcache configuration

Requirements

This package requires hyperf 2.1 or newer.

Installation

You can install the package via Composer:

composer require wilbur-yu/hyperf-opcache

If you need to change config values, you can publish the config file with:

php bin/hyperf.php vendor:publish wilbur-yu/hyperf-opcache

usage

  • config
php bin/hyperf.php opcache:config
  • status
php bin/hyperf.php opcache:status
  • clear
php bin/hyperf.php opcache:clear
  • compile
php bin/hyperf.php opcache:compile {--force}

Note: opcache.dups_fix must be enabled, or use the --force flag. If you run into "Cannot redeclare class" errors, enable opcache.dups_fix or add the class path to the exclude list.

Contributing

Thanks to the laravel-opcache and their contributors

License

The MIT License (MIT). Please see License File for more information.