sprintechnology/firebase-cloud-messaging

A bundle for Firebase cloud messaging

1.0.0 2018-01-18 11:56 UTC

README

Applications that use Symfony Flex

Open a command console, enter your project directory and execute:

$ composer require sprintechnology/firebase-cloud-messaging

Applications that don't use Symfony Flex

Step 1: Download the Bundle

Open a command console, enter your project directory and execute the following command to download the latest stable version of this bundle:

$ composer require sprintechnology/firebase-cloud-messaging

This command requires you to have Composer installed globally, as explained in the installation chapter of the Composer documentation.

Step 2: Enable the Bundle

Then, enable the bundle by adding it to the list of registered bundles in the app/AppKernel.php file of your project:

<?php
// app/AppKernel.php

// ...
class AppKernel extends Kernel
{
    public function registerBundles()
    {
        $bundles = array(
            // ...
            new Firebase\Bundle\CloudMessagingBundle\CloudMessagingBundle(),
        );

        // ...
    }

    // ...
}