phpmentors/pageflower-bundle

A pageflow engine for Symfony applications

Installs: 3 651

Dependents: 1

Suggesters: 0

Security: 0

Stars: 5

Watchers: 3

Forks: 4

Open Issues: 1

Type:symfony-bundle

v1.5.0 2020-06-19 01:21 UTC

This package is auto-updated.

Last update: 2022-11-19 07:04:28 UTC


README

A pageflow engine for Symfony applications

Total Downloads Latest Stable Version Latest Unstable Version Build Status

Features

  • Annotation-based page flow definition
  • Conversation management
  • Access-controlled actions
  • Conversation-scoped properties
  • User-defined methods to be called immediately after a conversation has started
  • Support for multiple browser windows or tabs

Installation

PHPMentorsPageflowerBundle can be installed using Composer.

First, add the dependency to phpmentors/pageflower-bundle into your composer.json file as the following:

Stable version:

composer require phpmentors/pageflower-bundle "1.5.*"

Development version:

composer require phpmentors/pageflower-bundle "~1.6@dev"

Second, add PHPMentorsPageflowerBundle into your bundles to register in AppKernel::registerBundles() as the following:

...
class AppKernel extends Kernel
{
    public function registerBundles()
    {
        $bundles = array(
            ...
            new PHPMentors\PageflowerBundle\PHPMentorsPageflowerBundle(),
        );
        ...

Support

If you find a bug or have a question, or want to request a feature, create an issue or pull request for it on Issues.

Copyright

Copyright (c) 2014-2015, 2018-2020 Atsuhiro Kubo, All rights reserved.

License

The BSD 2-Clause License