mglaman/authnet

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.
This package is abandoned and no longer maintained. The author suggests using the commerceguys/authnet package instead.

PHP SDK for Authorize.Net API, using Guzzle.

v1.1.2 2019-11-19 22:11 UTC

README

Scrutinizer Code Quality Build Status Code Coverage PackagistPackagist

An SDK for Authorize.net, using Guzzle.

Why not the official Authorize.net PHP SDK?

Dependencies

PHP version >= 5.5.0 is required.

The following PHP extensions are required:

  • json
  • simplexml
  • xmlwrite

This library also uses Guzzle 6.

Testing

PHPUnit

Run composer test, or ./vendor/bin/phpunit -c phpunit.xml.dist

Test Credit Card Numbers

Card Type Card Number
American Express 370000000000002
Discover 6011000000000012
Visa 4007000000027
4012888818888
4111111111111111
JCB 3088000000000017
Diners Club/ Carte Blanche 38000000000006
MasterCard 5424000000000015
2223000010309703
2223000010309711

See the Authorize.Net Testing Guide for more information.

License

See the LICENSE file.