lexpress/doctrine1

This package is abandoned and no longer maintained. The author suggests using the friendsofsymfony1/doctrine1 package instead.

PHP Database ORM for Symfony1. Do NOT use for new projects: please move to a newest Symfony release and Doctrine2

v1.4.0-RC2 2023-01-10 13:00 UTC

This package is auto-updated.

Last update: 2023-01-10 14:01:46 UTC


README

About this version

This is a community driven fork of doctrine 1, as official support has been interrupted long time ago.

Do not use it for new projects: this version is great to improve existing symfony1 applications using doctrine1, but Doctrine2 is the way to go today.

Requirements

PHP 5.3 and up.

Installation

Using Composer as dependency management:

composer require friendsofsymfony1/doctrine1 "1.5.*"
composer install

Tests

Prerequisites

  • docker-engine version 17.12.0+
  • docker-compose version 1.20.0+

How to execute all tests on all supported PHP versions and dependencies?

tests/bin/test

When you finish your work day, do not forget to clean up your desk

docker-compose down

Documentation

Read the official doctrine1 documentation

Contributing

You can send pull requests or create an issue.