lcobucci/kafka

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.

PHP client for Kafka

Fund package maintenance!
lcobucci
Patreon

0.1.x-dev 2021-10-01 20:08 UTC

README

Total Downloads Latest Stable Version Unstable Version

Build Status Code Coverage

A library to allow people to communicate to Kafka using plain PHP, compatible with Kafka v0.11+ (due to the way the protocol works).

Installation

Package is available on Packagist, you can install it using Composer.

composer require lcobucci/kafka

Dependencies

  • PHP 8.0+ (64-bit only)

Documentation

Architectural decisions

This project uses ADRs to record all architectural decisions. The summary can be found here.

License

MIT, see LICENSE.