jorisvanw/laravel-recurly

A simple Laravel 5 service provider for including the Recurly PHP client.

v2.0.2 2018-08-14 14:47 UTC

This package is auto-updated.

Last update: 2021-11-08 00:45:59 UTC


README

Latest Stable Version Total Downloads Build Status Coverage Status Donate

Integrates the Recurly API with Laravel 5.

A simple Laravel 5 service provider for including the Recurly PHP Client.

Installation

Use composer to install the package.

composer require jorisvanw/laravel-recurly

For laravel >=5.5 that's all. This package supports Laravel new Package Discovery.

If you are using Laravel < 5.5, you also need to add 'JorisvanW\LaravelRecurly\ServiceProvider' to your app/config/app.php providers array:

JorisvanW\LaravelRecurly\ServiceProvider::class,

Configuration

The defaults are set in app/config/recurly.php. Copy this file to your own config directory to modify the values. You can publish the config using this command:

$ php artisan vendor:publish --provider="JorisvanW\LaravelRecurly\ServiceProvider"

Add your Recurly information to the your .env file using the keys found in app/config/recurly.php.

Usage

http://docs.recurly.com/client-libraries/php