dynamic/flexslider

Display a FlexSlider on pages of your website

Installs: 23 576

Dependents: 3

Suggesters: 0

Security: 0

Stars: 7

Watchers: 5

Forks: 11

Open Issues: 17

Type:silverstripe-vendormodule


README

Build Status Scrutinizer Code Quality Code Coverage Build Status codecov.io

Latest Stable Version Total Downloads Latest Unstable Version License

Overview

The FlexSlider module allows a developer to attach a Woothemes FlexSlider to a Page or DataObject. Various options are built into the DataExtension to allow for some level of customization in the CMS.

Requirements

Installation

composer require dynamic/flexslider ^4.0

License

See License

Documentation

See the docs/en folder.

Troubleshooting

  • I've applied the FlexSlider DataExtension to a DataObject or Page and am receiving errors.
    • Be sure you have run a dev/build?flush=all
    • If this is an existing site installation and FlexSlider is being applied to existing records, be sure to run dev/tasks/SlideThumbnailNavMigrationTask. This will ensure default values expected for the module are setup for the existing records.

Translations

The translations for this project are managed via Transifex and are updated automatically during the release process. To contribute, please head to the link above and get translating!

Maintainer Contact

Bugtracker

Bugs are tracked in the issues section of this repository. Before submitting an issue please read over existing issues to ensure yours is unique.

If the issue does look like a new bug:

  • Create a new issue
  • Describe the steps required to reproduce your issue, and the expected outcome. Unit tests, screenshots and screencasts can help here.
  • Describe your environment as detailed as possible: SilverStripe version, Browser, PHP version, Operating System, any installed SilverStripe modules.

Please report security issues to the module maintainers directly. Please don't file security issues in the bugtracker.

Development and contribution

If you would like to make contributions to the module please ensure you raise a pull request and discuss with the module maintainers.