This package is abandoned and no longer maintained. The author suggests using the traderinteractive/util package instead.

A collection of utility classes

v2.0.0 2016-05-25 13:56 UTC


Build Status Scrutinizer Code Quality Code Coverage

Latest Stable Version Total Downloads License

A collection of general utilities for making common programming tasks easier.


util-php requires PHP 5.4 (or later).

##Composer To add the library as a local, per-project dependency use Composer! Simply add a dependency on dominionenterprises/util to your project's composer.json file such as:

    "require": {
        "dominionenterprises/util": "~1.0"


This package is a partial metapackage aggregating the following components:

##Documentation Found in the source itself, take a look!

##Contact Developers may be contacted at:

##Project Build With a checkout of the code get Composer in your PATH and run:


There is also a docker-based fig configuration that will execute the build inside a docker container. This is an easy way to build the application:

fig run build

For more information on our build process, read through out our Contribution Guidelines.