IRI value objects, parsers and formatters

0.1.1 2014-10-15 23:38 UTC


DataValues Iri is a small library that contains IRI value objects, parsers and formatters.

It is part of the DataValues set of libraries.

Build Status Code Coverage Scrutinizer Quality Score Dependency Status

On Packagist: Latest Stable Version Download count


The recommended way to use this library is via Composer.


To add this package as a local, per-project dependency to your project, simply add a dependency on data-values/iri to your project's composer.json file. Here is a minimal example of a composer.json file that just defines a dependency on version 1.0 of this package:

    "require": {
        "data-values/iri": "1.0.*"


Get the code of this package, either via git, or some other means. Also get all dependencies. You can find a list of the dependencies in the "require" section of the composer.json file. Then take care of autoloading the classes defined in the src directory.


This library comes with a set up PHPUnit tests that cover all non-trivial code. You can run these tests using the PHPUnit configuration file found in the root directory. The tests can also be run via TravisCI, as a TravisCI configuration file is also provided in the root directory.


DataValues Iri has been written by Jeroen De Dauw, as Wikimedia Germany employee for the Wikidata project.

Release notes

0.1.1 (2014-10-16)

  • Installation together with DataValues 1.x is now supported.

0.1 (2013-11-17)

Initial release with these features:

  • IriValue
  • IriFormatter