bartlett/php-compatinfo

Find out the minimum version and the extensions required for a piece of code to run

5.2.1 2019-10-21 18:37 UTC

README

Latest Stable Version Minimum PHP Version

Introduction

PHP CompatInfo is a library that can find the minimum version and the extensions required for a piece of code to run.

It is distributed as source code (install via composer) and a PHAR version that bundles all dependencies in a single file.

CAUTION: Branch 4.5 will not accept any more any feature requests.

CAUTION: Branch 5.0 will not accept any more any feature requests.

Requirements

  • PHP 5.5 or greater

Installation

You can either :

  • download the phar version 5.2.1
  • install via packagist the current source dev-master

PHP5 users only

Remove composer.lock to be able to install correct dependencies.

Content of this file in repository is for PHP7 users.

Documentation

The documentation for PHP CompatInfo 5.0 in English is available online or downloadable offline to read it later (multiple formats available).

AsciiDoc source code are available on docs folder of the repository.

Contributors

  • Laurent Laville
  • Thanks to Nikita Popov who wrote a marvellous https://github.com/nikic/PHP-Parser[PHP Parser] and simplify the job of PHP Reflect.
  • Thanks also to Remi Collet, a contributor of first hours.

License

This handler is licensed under the BSD-3-clauses License - see the LICENSE file for details