Wrapper for ext-swoole interchangeable with ext-openswoole

Installs: 2 634

Dependents: 4

Suggesters: 0

Security: 0

Stars: 0

Watchers: 1

Forks: 1

Open Issues: 0


v5.0.3 2023-02-08 01:45 UTC

This package is auto-updated.

Last update: 2023-09-12 18:01:15 UTC


The split of the Swoole community into Swoole and Open Swoole projects has left its ecosystem at crossroads: either stick with the original PHP extension or switch over to its fork.

Metapackages upscale/ext-swoole and upscale/ext-openswoole declare the two extensions as interchangeable. They enable PHP projects to support both extensions instead of choosing one or the other.


  • Unique version constraints for swoole and opensoole
  • Constraints resolution delegated to Composer
  • Metapackage ships no code, just constraints


Declare compatibility with both extensions in your composer.json:

     "require": {
-        "ext-swoole": "^4.0"
+        "upscale/ext-swoole": "^4.0",
+        "upscale/ext-openswoole": "^4.0"

Presence of either extension will satisfy the requirements.


This metapackage mirrors official releases of swoole/swoole-src. They are being tagged automatically.

Specify different constraints for each extension:

  "require": {
    "php": "~8.2.0",
    "upscale/ext-swoole": "^4.8.12",
    "upscale/ext-openswoole": "^4.12.0"


Copyright © Upscale Software. All rights reserved.

Licensed under the Apache License, Version 2.0.