Wrapper for ext-openswoole interchangeable with ext-swoole

Installs: 12 114

Dependents: 6

Suggesters: 0

Security: 0

Stars: 1

Watchers: 1

Forks: 0

Open Issues: 0


v22.1.2 2023-12-01 00:07 UTC

This package is auto-updated.

Last update: 2024-05-01 00:07:00 UTC


The split of the Swoole community into Swoole and Open Swoole projects has left its ecosystem at crossroads: either stick with the original PHP extension or switch over to its fork.

Metapackages upscale/ext-swoole and upscale/ext-openswoole declare the two extensions as interchangeable. They enable PHP projects to support both extensions instead of choosing one or the other.


  • Unique version constraints for swoole and opensoole
  • Constraints resolution delegated to Composer
  • Metapackage ships no code, just constraints


Declare compatibility with both extensions in your composer.json:

     "require": {
-        "ext-openswoole": "^4.0"
+        "upscale/ext-swoole": "^4.0",
+        "upscale/ext-openswoole": "^4.0"

Presence of either extension will satisfy the requirements.


This metapackage mirrors official releases of openswoole/ext-openswoole. They are being tagged automatically.

Specify different constraints for each extension:

  "require": {
    "php": "~8.2.0",
    "upscale/ext-swoole": "^4.8.12",
    "upscale/ext-openswoole": "^4.12.0"


Copyright © Upscale Software. All rights reserved.

Licensed under the Apache License, Version 2.0.