upscale/ext-openswoole

Wrapper for ext-openswoole interchangeable with ext-swoole

v22.0.0 2022-11-21 02:18 UTC

This package is auto-updated.

Last update: 2023-01-22 00:23:33 UTC


README

The split of the Swoole community into Swoole and Open Swoole projects has left its ecosystem at crossroads: either stick with the original PHP extension or switch over to its fork.

Metapackages upscale/ext-swoole and upscale/ext-openswoole declare the two extensions as interchangeable. They enable PHP projects to support both extensions instead of choosing one or the other.

Features:

  • Unique version constraints for swoole and opensoole
  • Constraints resolution delegated to Composer
  • Metapackage ships no code, just constraints

Usage

Declare compatibility with both extensions in your composer.json:

     "require": {
-        "ext-openswoole": "^4.0"
+        "upscale/ext-swoole": "^4.0",
+        "upscale/ext-openswoole": "^4.0"
     }

Presence of either extension will satisfy the requirements.

Versioning

This metapackage mirrors official releases of openswoole/swoole-src. They are being tagged automatically.

Specify different constraints for each extension:

{
  "require": {
    "php": "~8.2.0",
    "upscale/ext-swoole": "^4.8.12",
    "upscale/ext-openswoole": "^4.12.0"
  }
}

License

Copyright © Upscale Software. All rights reserved.

Licensed under the Apache License, Version 2.0.