php-ds/php-ds

Installs: 1 835 456

Dependents: 119

Suggesters: 4

Security: 0

Stars: 341

Watchers: 19

Forks: 35

Open Issues: 11

v1.4.0 2021-11-17 19:52 UTC

This package is auto-updated.

Last update: 2021-11-17 22:35:53 UTC


README

Build Status Packagist

This is a compatibility polyfill for the extension. You should include this package as a dependency of your project to ensure that your codebase would still be functional in an environment where the extension is not installed. The polyfill will not be loaded if the extension is installed and enabled.

Install

composer require php-ds/php-ds

You can also require that the extension be installed using ext-ds.

Test

composer install
composer test

Make sure that the ds extension is not enabled, as the polyfill will not be loaded if it is. The test output will indicate whether the extension is active.

Contributing

Please see CONTRIBUTING for more information.

Credits

License

The MIT License (MIT). Please see LICENSE for more information.