Yii2 Bootstrap Duallistbox Widget

0.1.1 2017-02-05 20:00 UTC


yii2 bootstrap-duallistbox wrapper of:

For plugin options, pls. check out the site from the plugin creator

Yii2 Extension by

Latest Stable Version Build Status Code Climate Version Eye License


Package is although registered at - so you can just add one line of code, to let it run!

add the following line to your composer.json require section:


or run:

$ php composer.phar require philippfrenzel/yii2bsduallistbox "*"

And ensure, that you have the following plugin installed global:

php composer.phar global require "fxp/composer-asset-plugin:~1.0"


04-02-2017 Initial upload


Quickstart Looks like this:

use net\frenzel\yii2bsduallistbox\yii2bsduallistbox;
    $options = [
        'multiple' => true,
        'size' => 20,

    // echo Html::listBox($name, $selection, $items, $options);
    echo yii2bsduallistbox::widget([
        'name' => $name,
        'selection' => $selection,
        'items' => $items,
        'options' => $options,
        'clientOptions' => [
            'moveOnSelect' => false,
            'selectedListLabel' => 'Selected Items',
            'nonSelectedListLabel' => 'Available Items',