ner0tic/jquery-plus-bundle

Bundle for Symfony2 containing often used jquery plugins

Installs: 22

Dependents: 0

Suggesters: 0

Security: 0

Stars: 0

Watchers: 2

Forks: 0

Open Issues: 0

Language:JavaScript

Type:symfony-bundle

1.0.2 2012-09-30 00:46 UTC

This package is not auto-updated.

Last update: 2022-11-26 05:39:51 UTC


README

Current Version

  • jQuery 1.8.2
  • JQuery-ui 1.8.23
  • Select2 3.2
  • GMaps 1.0

Installation

Add bundle to your composer.json file

// composer.json

{
    "require": {
		// ...
        "ner0tic/jquery-plus-bundle": "1.0.0"
    }
}

Add bundle to your application kernel

// app/AppKernel.php

public function registerBundles()
{
    $bundles = array(
        // ...
        new Ner0tic\JQueryPlusBundle\Ner0ticJQueryPlusBundle(),
        // ...
    );
}

Download the bundle using Composer

$ php composer.phar update ner0tic/jquery-plus-bundle

Install assets

Given your server's public directory is named "web", install the public vendor resources

$ php app/console assets:install web --symlink # drop the symlink flag to create copies instead

Usage

Twig

<script type="text/javascript" src="{{ asset('bundles/ner0ticjqueryplus/js/jquery.min.js') }}"></script>
<script type="text/javascript" src="{{ asset('bundles/ner0ticjqueryplus/js/jquery-ui.min.js') }}"></script>
<script type="text/javascript" src="{{ asset('bundles/ner0ticjqueryplus/js/select2.js') }}"></script>
<script type="text/javascript" src="{{ asset('bundles/ner0ticjqueryplus/js/gmaps.js') }}"></script>