middlewares/error-response

Middleware to handle responses with error status code (4xx-5xx)

v1.0.2 2020-12-03 01:13 UTC

This package is auto-updated.

Last update: 2022-04-29 01:16:37 UTC


README

Latest Version on Packagist Software License Testing Total Downloads

Middleware to format responses with HTTP error codes (4xx-5xx). Useful to create pretty 404 or 500 error pages.

Requirements

Installation

This package is installable and autoloadable via Composer as middlewares/error-response.

composer require middlewares/error-response

Example

use Middlewares\ErrorResponse;

Dispatcher::run([
    new Middlewares\ErrorResponse()
]);

Usage

The constructor accepts an array of responders, that must implement the Middlewares\ErrorResponder\ResponderInterface. This package includes two basic responders: for html and json responses, that are enabled by default if no responders are passed.

//The default responders (for html and js)
$responder = new Middlewares\ErrorResponse();

//Use your custom responders
$responder = new Middlewares\ErrorResponse([
    new MyHtmlResponder(),
    new MyJsonResponder()
]);

Please see CHANGELOG for more information about recent changes and CONTRIBUTING for contributing details.

The MIT License (MIT). Please see LICENSE for more information.