makogai/filament-non-typed

A collection of tools for rapidly building beautiful TALL stack interfaces, designed for humans.

Fund package maintenance!
danharrin

v2.10.48 2022-04-20 09:41 UTC

This package is auto-updated.

Last update: 2022-07-20 10:26:39 UTC


README

Banner

Tests passing Laravel v8.x Livewire v2.x PHP 8.0

Filament is a collection of tools for rapidly building beautiful TALL stack interfaces, designed for humans.

Packages

Admin Panel • DocumentationDemo

composer require filament/filament

Form Builder • Documentation

composer require filament/forms

Table Builder • Documentation

composer require filament/tables

Spatie Media Library Plugin • Documentation

composer require filament/spatie-laravel-media-library-plugin

Spatie Settings Plugin • Documentation

composer require filament/spatie-laravel-settings-plugin

Spatie Tags Plugin • Documentation

composer require filament/spatie-laravel-tags-plugin

Spatie Translatable Plugin • Documentation

composer require filament/spatie-laravel-translatable-plugin

Contributing

If you want to contribute to Filament packages, you may want to test it in a real Laravel project:

  • Fork this repository to your GitHub account.
  • Create a Laravel app locally.
  • Clone your fork in your Laravel app's root directory.
  • In the /filament directory, create a branch for your fix, e.g. fix/error-message.

Install the packages in your app's composer.json:

"require": {
    "filament/filament": "dev-fix/error-message as 2.x-dev",
    "filament/forms": "dev-fix/error-message as 2.x-dev",
    "filament/tables": "dev-fix/error-message as 2.x-dev",
},
"repositories": [
    {
        "type": "path",
        "url": "filament/packages/*"
    }
]

Now, run composer update.

Need Help?

🐞 If you spot a bug, please submit a detailed issue, and wait for assistance.

🤔 If you have a question or feature request, please start a new discussion. We also have a Discord community. For quick help, ask questions in the appropriate package help channel.

🔐 If you discover a vulnerability, please review our security policy.