lsys/entity

lsys module entity

Installs: 144

Dependents: 1

Suggesters: 0

Security: 0

Stars: 0

Watchers: 1

Forks: 0

Open Issues: 0

Language:C

0.0.1 2020-07-28 02:03 UTC

This package is auto-updated.

Last update: 2022-05-18 17:01:43 UTC


README

Build Status Coverage Status

主要用在数据库orm记录映射实体对象

  1. 默认使用 composer require lsys/entity 进行php 源码版本安装

  2. 如果追求最高执行效率,可以使用php扩展版本建议使用php>=7.2(官方7.1测试通过),git clone 后如下安装并在php.ini添加引入:

cd ext
phpize && ./configure 
make && sudo make install
  1. windows 版的dll请在 https://github.com/php-lsys/entity/releases 下载

默认请使用composer 方式安装,当编译有扩展时,会优先使用扩展的实现,否则会用php源码版本.