ibrows/datatrans-bundle

Ibrows Datatrans Symfony Integration

2.0.1 2017-06-16 08:18 UTC

This package is auto-updated.

Last update: 2024-07-22 14:46:50 UTC


README

Features

  • Provides a datatrans implementation within symfony

Requirements

  • PHP 5.3+

Installation

Through Composer

{
    "require": {
        "ibrows/datatrans-bundle": "dev-master@dev"
    }
    "repositories": [
        {
          "type": "vcs",
          "url": "git@codebasehq.com:ibrows/ibrowsch/datatransbundle.git"
        }
    ]
}

Advanced Installation

Replace Logger

You can use each psr-3 implementation, create your own service and add its id to the bundle configuration.

ibrows_data_trans:
    logger: my_logger_serviceid  # or logger if you like symfony default

Replace Validator

Create your own service and add its id to the bundle configuration.

ibrows_data_trans:
    logger: my_validator_serviceid  # or logger if you like symfony default

Usage

Authorization

/** @var Ibrows\DataTrans\Api\Authorization\Add\Authorization $authorization */
$authorization = $container->get('ibrows.datatrans.service.authorization');

For details, watch the datatrans library