http-interop/http-server-middleware

This package is abandoned and no longer maintained. The author suggests using the psr/http-server-middleware package instead.

Common interface for HTTP server-side middleware

1.1.1 2018-01-23 14:34 UTC

README

Deprecation warning!

Starting January 22nd, 2018 http-interop is officially deprecated in favor of PSR-15.

From v1.1, this package directly extends PSR-15 interfaces to provide backwards compatibility and should no longer be added to new projects.

Please switch to psr/http-server-middleware as soon as possible.

Version Constraint Warning

To continue using this package for backwards compatibility, use the following version constraint to avoid a type error:

{
    "require": {
        "http-interop/http-server-middleware": "^1.1.1"
    }
}

See issue #6 for details.

Changes Required

There are two changes required to use the official psr/http-server-middleware package:

Update Composer

Replace the line in composer.json that reads:

{
    "require": {
        "http-interop/http-server-middleware": "^1.0"
    }
}

with:

{
    "require": {
        "psr/http-server-middleware": "^1.0"
    }
}

Update Code

Replace any references to:

use Interop\Http\Server\MiddlewareInterface;

with:

use Psr\Http\Server\MiddlewareInterface;