hiqdev/yii2-language

Yii2 module for language switching

Installs: 8 158

Dependents: 6

Suggesters: 0

Stars: 8

Watchers: 3

Forks: 2

Open Issues: 1

Type:yii2-extension

0.1.0 2017-05-06 14:45 UTC

README

Yii2 module for language switching

Latest Stable Version Total Downloads Build Status Scrutinizer Code Coverage Scrutinizer Code Quality Dependency Status

This Yii2 extension provides language switching module.

This extension provides:

  • module with controller and language select action
    • auto detection of acceptable languages
    • saving selected language to cookie
  • widget for displaying language selection menu

Installation

The preferred way to install this yii2-extension is through composer.

Either run

php composer.phar require "hiqdev/yii2-language"

or add

"hiqdev/yii2-language": "*"

to the require section of your composer.json.

Usage

Example application configuration:

    'modules' => [
        'language' => [
            'class' => \hiqdev\yii2\merchant\Module::class,
            'languages' => [
                'en' => 'English',
                'ru' => 'Русский',
            ],
        ],
    ],

License

This project is released under the terms of the BSD-3-Clause license. Read more here.

Copyright © 2016-2017, HiQDev (http://hiqdev.com/)