heyday/silverstripe-adaptivecontent

There is no license information available for the latest version (4.0.0-alpha) of this package.

SilverStripe Adaptive Content

Installs: 1 164

Dependents: 0

Suggesters: 0

Security: 0

Stars: 2

Watchers: 25

Forks: 4

Type:silverstripe-module

4.0.0-alpha 2020-02-07 02:04 UTC

README

Generic sets of fields as data extensions. Originally intended to be the back-end for an "adaptive" content strategy (content adapting to device/context), but generally quite useful as a set of common, reusable fields.

See 1.0 branch for SilverStripe 2.4 compatible version.

Installation (with composer)

$ composer require heyday/silverstripe-adaptivecontent:~3.0

Usage

The main component of this module can be used simply by adding the AdaptiveContent extension to a dataobject or page:

SomeDataObject:
  extensions:
    - AdaptiveContent

The other field extensions work in the same way:

SomePage:
  extensions:
    - AdaptiveContent
    - AdaptiveContentHierarchy
    - AdaptiveContentRelated('Page')

Example use

See heyday/silverstripe-slices for an example use of this module.

Unit testing

$ composer install --dev
$ vendor/bin/phpunit