Provides a simple abstraction over streams of data

Installs: 4 339 424

Dependents: 16

Stars: 29

Watchers: 6

Forks: 16

Open Issues: 4

Language: PHP

3.0.0 2014-10-12 19:18 UTC


Provides a simple abstraction over streams of data.

This library is used in Guzzle 5, and is (currently) compatible with the WIP PSR-7.


This package can be installed easily using Composer. Simply add the following to the composer.json file at the root of your project:

  "require": {
    "guzzlehttp/streams": "~3.0"

Then install your dependencies using composer.phar install.


The documentation for this package can be found on the main Guzzle website at


This library is tested using PHPUnit. You'll need to install the dependencies using Composer then run make test.