getpop/api-graphql

Extended/Upgraded implementation of GraphQL, implemented on PHP, based on the PoP API

0.8.8 2021-09-27 06:44 UTC

This package is auto-updated.

Last update: 2021-10-08 07:45:30 UTC


README

Extended/Upgraded implementation of GraphQL. This implementation is a package to be installed on top of the PoP API.

Install

Via Composer

composer require getpop/api-graphql

Development

The source code is hosted on the PoP monorepo, under API/packages/api-graphql.

To enable pretty API endpoint /api/graphql/, follow the instructions here

Note: if you wish to install a fully-working API, please follow the instructions under Bootstrap a PoP API for WordPress (even though CMS-agnostic, only the WordPress adapters have been presently implemented).

Usage

Initialize the component:

\PoP\Root\AppLoader::addComponentClassesToInitialize([
    \PoP\GraphQLAPI\Component::class,
]);

Features

Everything from the API layer, adapted to GraphQL

The API layer provides plenty of features, based on the field-query syntax.

This package adapts all those features to GraphQL.

Automatic namespacing of types

Namespaces (proposed to be added to the GraphQL spec) help manage the complexity of the schema. This can avoid different types having the same name, which can happen when embedding components from a 3rd party.

This is how the normal schema looks like in the GraphQL Voyager:

Interactive schema

This is how it looks in its namespaced version:

Namespaced interactive schema

Field/directive-based versioning

Fields and directives can be independently versioned, and the version to use can be specified in the query through the field/directive argument versionConstraint.

To select the version for the field/directive, we use the same semver version constraints employed by Composer.

In this query, field userServiceURLs has 2 versions, 0.1.0 and 0.2.0:

Querying a field using by version

Let's use constraints with ^ and > to select the version. In this query, constraint "^0.1" is resolved to version "0.1.0", but constraint ">0.1" is resolved to version "0.2.0":

Querying a field using version constraints

This query demonstrates it for directives:

Querying a directive using version constraints

Adding the versionConstraint parameter in the GraphQL endpoint itself will implicitly define that version constraint in all fields, and any field can still override this default value with its own versionConstraint, as in this query:

Overriding a default version constraint

PHP versions

Requirements:

  • PHP 8.0+ for development
  • PHP 7.1+ for production

Supported PHP features

Check the list of Supported PHP features in leoloso/PoP

Preview downgrade to PHP 7.1

Via Rector (dry-run mode):

composer preview-code-downgrade

Standards

PSR-1, PSR-4 and PSR-12.

To check the coding standards via PHP CodeSniffer, run:

composer check-style

To automatically fix issues, run:

composer fix-style

Change log

Please see CHANGELOG for more information on what has changed recently.

Testing

To execute PHPUnit, run:

composer test

Static Analysis

To execute PHPStan, run:

composer analyse

Report issues

To report a bug or request a new feature please do it on the PoP monorepo issue tracker.

Contributing

We welcome contributions for this package on the PoP monorepo (where the source code for this package is hosted).

Please see CONTRIBUTING and CODE_OF_CONDUCT for details.

Security

If you discover any security related issues, please email leo@getpop.org instead of using the issue tracker.

Credits

License

GNU General Public License v2 (or later). Please see License File for more information.