fractaslabs/silverstripe-googleanalytics

This package is abandoned and no longer maintained. The author suggests using the fractas/googleanalytics package instead.

Fast, configurable and simple Google Analytics module with support for multiple GA ID's

3.0 2019-02-01 11:46 UTC

README

Latest Stable Version Latest Unstable Version Total Downloads License

Overview

Fast, configurable, simple Google Analytics and Google Tag Manager module with support for multiple GA ID's

Requirements

  • SilverStripe Framework 4

Version info

The master branch of this module is currently aiming for SilverStripe 4.x compatibility

Installation

  • Install via Composer

    composer require "fractas/googleanalytics" "^3.0"
    
  • Add to your mysite.yml configuration file your Google Analytics ID, and enable extra features (if needed):

    Fractas\GoogleAnalytics\GoogleAnalyticsController:
      enable_display_features: true # https://developers.google.com/analytics/devguides/collection/analyticsjs/display-features
      enable_in_dev: false
      ga_id: UA-xxxxxxxx-x0 #main Google Analytics ID property
      gtm_id: GTM-xxxxxxxx #Google Tag Manager ID
      ga_extra_ids:
        newTracker1: UA-xxxxxxxx-x1 #you can add multiple Google Analytics ID properties
        newTracker2: UA-xxxxxxxx-x2
        newTrackerX: UA-xxxxxxxx-xX
  • Run flush=all in your browser

Bugtracker

Bugs are tracked on github.com

Licence