flagrow/linguist

This package is abandoned and no longer maintained. The author suggests using the fof/linguist package instead.

Customize translations

Installs: 2 725

Dependents: 0

Suggesters: 0

Stars: 6

Watchers: 3

Forks: 4

Open Issues: 2

Language:JavaScript

Type:flarum-extension

0.3.1 2019-04-14 19:09 UTC

README

MIT license Latest Stable Version Total Downloads Support Us Join our Discord server

With this extension you can configure alternate or missing translation strings for your forum. Includes:

  • No manual translation file editing required, everything is configured via the admin UI
  • Translate frontend or backend strings
  • Override the translation for a specific locale or all installed locales
  • Easily search for strings by name or value in any language
  • Multiple filters to find strings that are missing translations or belong to a specific extension

Don't forget to clear the cache with php flarum cache:clear if the new translations aren't showing up.

Want to clear the cache via the admin panel ? We recommend using Reflar UnCache for that.

Also note Flarum uses a "one place, one translation key" approach to translations, so you might have to edit several keys to replace a specific keyword.

Installation

Use Bazaar or install manually:

composer require flagrow/linguist

Updating

composer update flagrow/linguist
php flarum migrate
php flarum cache:clear

Configuration

Once enabled, a new tab will show up in the admin to configure translations.

The tab will list all translations strings registered by extensions on your forum. You can customize the text by entering your own value in the field.

A special field "all" allows you to define a single text that will be shown in all languages.

Keep in mind some strings contain references in the form {referencename} that you have to keep identical if you want the data to show up.

Support our work

Check out how to support Flagrow extensions at flagrow.io/support-us.

Security

If you discover a security vulnerability within Linguist, please send an email to the Gravure team at security@gravure.io. All security vulnerabilities will be promptly addressed.

Please include as many details as possible. You can use php flarum info to get the PHP, Flarum and extension versions installed.

Links

An extension by Flagrow, a project of Gravure.