Constant Contact PHP SDK for v2

Installs: 31 057

Dependents: 2

Stars: 61

Watchers: 38

Forks: 76

Open Issues: 7

2.1.3 2016-02-02 19:48 UTC


Build Status Latest Stable Version Latest Unstable Version

This library utilizes GuzzlePHP

Installing via Composer

Composer is a dependency management tool for PHP that allows you to declare the dependencies your project needs and installs them into your project. In order to use the Constant Contact PHP SDK through composer, you must add "constantcontact/constantcontact" as a dependency in your project's composer.json file.

        "require": {
            "constantcontact/constantcontact": "2.1.*"

Or, if you would like a more bleeding edge build, which has features like the newest version of GuzzlePHP and a minimum of PHP 5.5, you can build off our development branch.

        "require": {
            "constantcontact/constantcontact": "dev-development"

Manual Installation

Manual installation is not recommended, as this library relies on other Composer libraries to function. Getting started with composer is easy!

If you require manual installation, it is recommended that you use version 1. Composer handles all of the dependencies that this library requires in version 2.


The source documentation is hosted at

API Documentation is located at


The ConstantContact class contains the underlying services that hold the methods that use the API.

use Ctct\ConstantContact;
$cc = new ConstantContact('your api key');

$contacts = $cc->contactService->getContacts('your access token')

Many methods will take an array of parameters for use in the calls. Available params are documented in the PHPDoc of the method.

$params = array("limit" => 500);
$contacts = $cc->contactService->getContacts('your access token', $params);

Minimum Requirements

Use of this library requires PHP 5.4+

If you are being required to use an older version of PHP, it is highly recommended that you update to at least 5.4 - but you can use version 1.3.* (PHP 5.3+) via composer, or manually (but note that versions 2 and up require other dependencies).