codeigniter4/codeigniter4-standard

CodeIgniter 4 Standard for PHP_CodeSniffer 3.

Installs: 132 310

Dependents: 28

Suggesters: 0

Security: 0

Stars: 64

Watchers: 18

Forks: 14

Open Issues: 7

Type:phpcodesniffer-standard

v1.1.1 2021-03-05 09:34 UTC

This package is auto-updated.

Last update: 2021-04-27 16:58:35 UTC


README

CodeIgniter 4 coding standard for use with PHP_CodeSniffer 3.

Version 1

Master Develop
Build Status Build Status
Coverage Status Coverage Status

This is currently a work in progress.

Requested at: https://github.com/bcit-ci/CodeIgniter4/issues/182

Requirements

PHP_CodeSniffer 3. (3.1.1 or greater).

PHP (7.1 or greater) with mbstring extension.

Install

Composer install

cd /Path/To/MyProject composer require codeigniter4/codeigniter4-standard --dev

Set the phpcs standard path and phpcbf standard path in your editor/plugin config to:

/Path/To/MyProject/vendor/codeigniter4/codeigniter4-standard/CodeIgniter4/ruleset.xml

Download install

Download CodeIgniter4-Standard.

Set standard paths to your local filesystem:

'/Path/To/CodeIgniter4-Standard/CodeIgniter4/ruleset.xml'

Global install

Globally install PHP_CodeSniffer with one of the various methods.

Once complete you should be able to execute phpcs -i on the command line.

You should see something like:-

The installed coding standards are MySource, PEAR, PSR1, PSR2, Squiz and Zend.

Either clone this repository...

git clone -b master --depth 1 https://github.com/bcit-ci/CodeIgniter4-Standard.git.

or use composer...

composer global require codeigniter4/codeigniter4-standard

or download.

Take note of the paths where they were installed.

Create a symbolic link to the CodeIgniter4-Standard/CodeIgniter4 directory in php_codesniffer/src/Standards/ eg.

ln -s ~/Documents/Projects/CodeIgniter4-Standard/CodeIgniter4 ~/.composer/vendor/squizlabs/php_codesniffer/src/Standards/CodeIgniter4

or copy the CodeIgniter4-Standard/CodeIgniter4 directory to php_codesniffer/src/Standards/

Executing phpcs -i should now show CodeIgniter4 installed eg.

The installed coding standards are CodeIgniter4, MySource, PEAR, PSR1, PSR2, Squiz and Zend.

You should now be able to set 'CodeIgniter4' as the phpcs standard in the plugin/editor/IDE of your choice.

Command line use

Sniffing errors & warnings (reporting).

Single file...

phpcs /Path/To/MyFile.php --standard='/Path/To/CodeIgniter4-Standard/CodeIgniter4/ruleset.xml'

or if globally installed.

phpcs /Path/To/MyFile.php --standard=CodeIgniter4

Directory (recursive).

phpcs /Path/To/MyProject --standard='/Path/To/CodeIgniter4-Standard/CodeIgniter4/ruleset.xml'

or if globally installed.

phpcs /Path/To/MyProject --standard=CodeIgniter4

Fixing fixable errors.

Single file.

phpcbf /Path/To/MyFile.php --standard='/Path/To/CodeIgniter4-Standard/CodeIgniter4/ruleset.xml'

or if globally installed.

phpcbf /Path/To/MyFile.php --standard=CodeIgniter4

Directory (recursive).

phpcbf /Path/To/MyProject --standard='/Path/To/CodeIgniter4-Standard/CodeIgniter4/ruleset.xml'

or if globally installed.

phpcbf /Path/To/MyProject --standard=CodeIgniter4

Credits

Thanks to Greg Sherwood, Marc McIntyre, Andy Grunwald, Thomas Ernest and Erik Torsner, for providing open source code which helped me build this standard and a big thanks to Squiz Labs for creating PHP_CodeSniffer.

Thanks to EllisLab for originally creating CodeIgniter and the British Columbia Institute of Technology for continuing the project. Thanks to all the developers and contibutors working on CodeIgniter 4.