cartalyst/sentry

PHP 5.3+ Fully-featured Authentication & Authorization System

Installs: 425 867

Dependents: 105

Stars: 1 615

Watchers: 134

Forks: 361

Open Issues: 3

Language: PHP

v2.1.5 2015-03-06 03:17 UTC

README

Help Support Sentinel version 3

http://igg.me/at/sentinel-open-source

This package is DEPRECATED, please check our Sentinel package for a better authentication & authorization system.

Sentry is a PHP 5.3+ fully-featured authentication & authorization system. It also provides additional features such as user groups and additional security features.

Sentry is a framework agnostic set of interfaces with default implementations, though you can substitute any implementations you see fit.

Build Status

Bitdeli

Features

It also provides additional features such as user groups and additional security features:

  • Configurable authentication (can use any type of authentication required, such as username or email)
  • Authorization
  • Activation of user (optional)
  • Groups and group permissions
  • "Remember me"
  • User suspension
  • Login throttling (optional)
  • User banning
  • Password resetting
  • User data
  • Interface driven - switch out your own implementations at will

Installation

Installation of Sentry is very easy. We've got a number of guides to get Sentry working with your favorite framework or on it's own:

Getting Started

Upgrading

Currently, we do not have an upgrade method from Sentry 1, however we may be able to publish one before the stable release of Sentry 2.0. When upgrading between betas or release-candidates, please see our changelog.

Support

We offer support through our help forums, on IRC at #cartalyst and through GitHub issues (bugs only).

If you like Sentry, consider subscribing to our Arsenal. It allows us to keep creating awesome software and afford to eat at night. Subscribers also get priority support with all of our packages, both free and subscriber-only.