bmatzner/lodash-bundle

Lo-Dash Bundle for Symfony2

Installs: 5 704

Dependents: 0

Suggesters: 0

Stars: 0

Watchers: 1

Forks: 1

Open Issues: 0

Language:JavaScript

Type:symfony-bundle

4.17.4 2017-01-09 09:13 UTC

README

Lo-Dash Bundle for Symfony2

Notice

This is a legacy bundle dating back to when javascript packagers such as NPM or Bower didn't exist. No further updates to this bundle will be published, so please consider the bundle abandoned.

Current Version

Lo-Dash v4.17.4

Installation

Add bundle to your composer.json file

// composer.json

{
    "require": {
		// ...
        "bmatzner/lodash-bundle": "~4.17"
    }
}

Add bundle to your application kernel

// app/AppKernel.php

public function registerBundles()
{
    $bundles = array(
        // ...
        new Bmatzner\LoDashBundle\BmatznerLoDashBundle(),
        // ...
    );
}

Download the bundle using Composer

$ php composer.phar update bmatzner/lodash-bundle

Install assets

Given your server's public directory is named "web", install the public vendor resources

$ php app/console assets:install web

Optionally, use the --symlink attribute to create links rather than copies of the resources

$ php app/console assets:install --symlink web

Usage

Refer to the desired files in your HTML template, e.g.

<script type="text/javascript" src="{{ asset('bundles/bmatznerlodash/js/lodash.min.js') }}"></script>

Licenses

Refer to the source code of the included files for license information

References

  1. http://lodash.com/
  2. http://symfony.com/