behat/mink-sahi-driver

This package is abandoned and no longer maintained. No replacement package was suggested.

Sahi.JS driver for Mink framework

v1.2.1 2016-03-05 09:36 UTC

README

Latest Stable Version Latest Unstable Version Total Downloads Build Status Scrutinizer Quality Score Code Coverage License

Usage Example

<?php

use Behat\Mink\Mink,
    Behat\Mink\Session,
    Behat\Mink\Driver\SahiDriver;

$startUrl = 'http://example.com';

$mink = new Mink(array(
    'sahi' => new Session(new SahiDriver('firefox')),
));

$mink->getSession('sahi')->getPage()->findLink('Chat')->click();

Installation

{
    "require": {
        "behat/mink":              "~1.5",
        "behat/mink-sahi-driver":  "~1.1"
    }
}
$> curl -sS https://getcomposer.org/installer | php
$> php composer.phar install

Maintainers