arcanedev/stripe

4.10.0 2017-05-26 17:41 UTC

README

Travis Status Coverage Status Scrutinizer Code Quality SensioLabs Insight Github Issues

Packagist Packagist Release Packagist Downloads

By ARCANEDEV©

You can sign up for a Stripe account at https://stripe.com.

Requirements

- PHP >= 5.6.0
- ext-curl: *
- ext-json: *
- ext-mbstring: *

INSTALLATION

Composer

You can install the bindings via Composer. By running composer require arcanedev/stripe.

USAGE

Simple usage looks like :

require_once('vendor/autoload.php');

use Arcanedev\Stripe\Stripe;
use Arcanedev\Stripe\Resources\Charge;

Stripe::setApiKey('your-stripe-api-key');

$charge = Charge::create([
    'card'     => [
        'number'    => '4242424242424242',
        'exp_month' => 8,
        'exp_year'  => 2018,
    ],
    'amount'   => 2000,
    'currency' => 'usd'
]);

var_dump($charge);

Documentation

Please see Stripe API Reference for up-to-date documentation.

Contribution

Any ideas are welcome. Feel free to submit any issues or pull requests, please check the contribution guidelines.

Security

If you discover any security related issues, please email arcanedev.maroc@gmail.com instead of using the issue tracker.

Credits