appshed/extension-api

API for AppShed remote screens

Installs: 162

Dependents: 0

Stars: 2

Watchers: 3

Forks: 2

Language: PHP

3.1.2 2015-06-22 11:06 UTC

README

This is the api for remote screens.

Latest Stable Version License Build Status SensioLabsInsight

Installing

Composer

You can install the API in your project just run composer require appshed/extension-api.

Phar

If you don't want to use composer, you can download the phar. This is a package of everything you need, you just need to require_once 'appshed-api.phar'. Look in the phar-examples folder to see how it might be used.

Examples

Be sure to run composer install if you want to run the examples from this repo.

Docs

You can see the api docs on github pages.

Contributing

Phar

Please be sure to update the phar before committing. You need to use Box to do this.

To build the phar:

./vendor/bin/box build -v

Docs

The API doc is built using sami.

To generate the API doc:

./vendor/bin/sami.php update sami.php 

You can then commit the doc folder to the gh-pages branch, something like:

mv doc ~/doc-tmp
git checkout gh-pages
rm -rf .
mv ~/doc-tmp/* .
git add .
git commit

Tests

To run the tests

./vendor/bin/phpunit